Search

GlobalSCAPE Knowledge Base

EFT fails to start one or more Sites

Karla Marsh
EFT

THE INFORMATION IN THIS ARTICLE APPLIES TO:

  • EFT, v7.4.13

SYMPTOM

EFT fails to start one or more Sites

CAUSE

EFT falsely determines that the Site's ports are in use, because the ports were not de-allocated before the service restart has completed—usually due to powerful hardware causing service restart to happen with little to no delay.

RESOLUTION

Configure the following registry settings to insert a slight delay before restarting, or retry Site start a few times when the initial attempt fails.

​In EFT v8.0, all registry settings were moved to AdvancedProperties.json. For information about Advanced Properties, refer to the online help for your version of EFT.

HKEY_LOCAL_MACHINE\Software\WOW6432Node\GlobalSCAPE Inc.\EFT Server 7.4\

Value name: SiteStartDelay

Type: DWORD

Default Value: 0 = no delay (default behavior); any other decimal value = milliseconds to insert a delay before the initial start

Cached: yes

Backup/Restore: yes

Value name: SiteStartRetries

Type: DWORD 

Default Value: 0 = no retry (default behavior); any other decimal value = number of retries

Cached: yes

Backup/Restore: yes

Value name: SiteStartRetryDelay

Type: DWORD

Default Value: 0 = no retry delay(default behavior); any other decimal value = retry delay in milliseconds

Cached: yes

Backup/Restore: yes

Details
Last Modified: 3 days ago @ 8:04 PM
Last Modified By: kmarsh
Type: HOTFIX
Rated 2 stars based on 1 vote
Article has been viewed 10K times.
Options
Also In This Category
Tags