Search

GlobalSCAPE Knowledge Base

Upgrading to v8.0.7

Karla Marsh
EFT

THE INFORMATION IN THIS ARTICLE APPLIES TO:

  • EFT v8.0.7 and later

For upgrading EFT prior to v8.0.7, refer to https://kb.globalscape.com/Knowledgebase/11194/Upgrading-EFT-v7x-806.

See also: https://kb.globalscape.com/Knowledgebase/11566/Registration-Support-for-Migrated-Environments for details of registering the Advanced Authentication Modes or Regulatory Compliance modules using your existing serial numbers for the ASM or ESM.

 DISCUSSION

This article describes the supported upgrade scenarios with a licensed version of EFT Enterprise or EFT Express, and EFT modules.

For details of which features are available in which module, refer to the "Feature Availability" chart in the v8.0.7 online help.

Upgrading notes for v8.0.7:

​During upgrade, the name of the server service will be different; therefore, you will lose the connection to the server service Log On account. Refer to Windows Account for the EFT Server Service for details of adding the "Log on as" account for the EFT server service.

Contact Support to obtain a new registration serial number or to determine your eligibility for an upgrade. If you are moving an EFT from one computer to another, contact the Globalscape customer service team or your account manager so that we can adjust your account on our activation and registration server. Activation on the new computer will not be possible until the adjustment is made. If you want to test or verify an update prior to introduction into your production environment, do not use your production serial number for testing purposes.

When using a pre-8.0.7 Advanced Security Module (ASM) or Express Security Module (ESM) serial number, if you are moving EFT from one computer to another, and are planning on using a serial number for Advanced Security Module (ASM) or Express Security Module (ESM), please contact your account manager so that they can provide you with an EFT 8.0.7 serial number for Regulatory Compliance Module (RCM) or Advanced Authentication Modes (AAM) . See also: https://kb.globalscape.com/Knowledgebase/11566/Registration-Support-for-Migrated-Environments 
* EFT ASM serial number will grant you access to both the RCM and AAMM
* EFT ESM serial number will grant you access only to RCM, and not the AAMM

  • Each of the features you currently have registered will still be licensed/registered after upgrading (just packaged differently or renamed as described below).
  • If you want to register a new module, please register EFT "core" first to avoid any problems. If you register the EFT modules before the main EFT v8.0.7 license, the EFT server registration in the administration interface Help drop-down will appear dimmed.
  • When registering a new installation of EFT 8.0.7, it has been found that if you register a module before you register the EFT license, the server will act as though EFT has already been registered. That is, in Help > About it will show the module registered, but it will reference the same key as the module that was registered before EFT.
  • If you run into an issue where your EFT server license will not work, please contact support. Do not enter any other serial numbers until EFT has been registered.
  • If you register a module without first registering EFT, then our registration process does not work properly and you might have troubles should you need support.
  • Registration of EFT 8.0.7 with older EFT Server Enterprise/Express serial numbers are supported; this will unlock certain features similar to an upgrade scenario.
  • Manual registration of EFT 8.0.7 with older EFT Server Enterprise/Express is supported, however, you will need to reach our customer support team to help you properly register EFT.
  • EFT 8.0.7 does not support DMZ single site registration via manual registration.

Mapping of Old and New Acronyms

If the "old" module (or feature) is currently licensed, it will convert to the new module during upgrade. For example, if you licensed the Express Security Module (ESM) in EFT Express, you will now have the Regulatory Compliance Module (RCM) after upgrade. If you licensed the Advanced Security Module (ASM) in EFT Enterprise, you will now have the Advanced Authentication Modes module (AAMM) and the RCM after upgrade. (The AAM includes support for CAC, RADIUS, RSA SecurID, SAML, and MFA; RCM includes PCI DSS and GDPR features.) After you've upgraded EFT, the Help menu and the About tab in the EFT administration interface will display the new modules and indicate what was upgraded. ​Also, various settings in the administration interface will display an asterisk next to it to indicate that a module is required to enable that feature.

On this new platform, you are not losing any features, they're just being grouped into modules. You can now license any of the modules--you no longer need an "enterprise" license to license the AWE and AS2 modules, or the Advanced Authentication modes (CAC, LDAP, SAML, RADIUS, RSA, SMS)--and new modules with features previously available only to EFT Enterprise, such as encrypted folders, delegated administration, backup/restore, and so many other features.

  • Please register EFT "Core" before registering any new modules (You won't need to register any new modules if you already have the features that you want. The license will automatically "transfer" during upgrade.)
  • Use the "Upgrade" option in the EFT installer wizard to upgrade.
  • Refer to "Upgrading Notes" in the online help for important version-related considerations
  • Refer to the Globalscape Knowledgebase topic #11194 for more information about upgrading EFT.
Old New Description
ASM AAMM Advanced Authentication Modes Module (CAC, RADIUS, RSA SecurID, SAML, and MFA) 
ARM ARM Auditing Reporting Module
AS2 AS2 AS2 for B2B
AWE AWM Automate Workflows Module
CCM CCM Cloud Connector Module
ESM RCM Regulatory Compliance module (PCI DSS and GDPR features)
FMM FMM Folder Monitor Event Module
FTC FTC File Transfer Client Module
X FTPS FTPS Module
X EAM Enterprise Actions Module (Event Rules)
GWC GWS DMZ Gateway Single-site
GWD GWM DMZ Gateway Multi-site
HTTP HTTPS HTTPS Module (includes Web client)
PGP PGP OpenPGP Module
RAM RAM Remote Automation Module (formerly Remote Agent Module)
x SFM Secure Forms Module
SFTP SFTP SFTP Module
TEM TEM Timer Event Module
WS WMU Workspaces Module (unlimited)

EFT Enterprise Upgrades

When upgrading from EFT Enterprise, the following modules will be licensed:

  • EFT 8 Core
  • FTP/s Module (FTPS)
  • SFTP Module
  • HTTP/s Module
  • Enterprise Actions Modes
  • Folder Monitor Module (FMM)
  • Timer Event Module (TEM)
  • File Transfer Client Module (FTC)
  • Cloud Connector Module (CCM)
  • Secure Forms Module (SFM)

When you are upgrading from EFT Enterprise with registered modules, the modules above will be licensed, plus the modules you had licensed before upgrading. For example: 

  • EFT 8 Core
  • SFTP Module
  • HTTP/s Module
  • Enterprise Actions Modes (EAM)
  • Folder Monitor Module (FMM)
  • Timer Event Module (TEM)
  • File Transfer Client Module (FTC)
  • Cloud Connector Module (CCM)
  • FTP/s Module (FTPS)
  • Secure Forms Module (SFM)

Plus:

  • If ASM was registered, you now have the Regulatory Compliance Module (RCM) and Advanced Authentication Modes module (AAMM).
  • ARM, AS2, OpenPGP, AWM, Workspaces, Remote Agent (now "Remote Automation"), DMZ Gateway Multi-site or Single-site were registered, they remain the same.

The same is true for Monthly or Yearly subscriptions; that is, the modules will convert to the new format. (And will still be monthly or yearly subscriptions; it will not convert to a perpetual license.)

EFT Express Upgrades

When upgrading from EFT Express (perpetual license), the following modules will be licensed:

  • EFT 8 Core
  • FTP/s Module (FTPS)
  • Enterprise Actions Module (EAM)

When you are upgrading from EFT Express with registered modules, the "core" and FTPS modules will be licensed, plus the modules you had licensed in Express before upgrading. For example: 

  • EFT 8 Core
  • FTP/s Module (FTPS)
  • Enterprise Actions Module (EAM)

Plus any of these that you had licensed:

  • If any of SFTP Module, HTTP/s Module, Folder Monitor Module (FMM), Timer Event Module (TEM), File Transfer Client Module (FTC), Cloud Connector Module (CCM), ARM, OpenPGP, Workspaces, Remote Agent (now "Remote Automation"),  or DMZ Gateway single-site were registered, they are still.
  • If ESM was registered, you now have the Regulatory Compliance Module (RCM).

The same is true for Monthly or Yearly subscriptions; that is, the modules will convert to the new format. (And will still be monthly or yearly subscriptions; it will not convert to a perpetual license.)

Details
Last Modified: 6 days ago @ 4:10 PM
Last Modified By: kmarsh
Type: HOWTO
Rated 3 stars based on 4 votes.
Article has been viewed 2.9K times.
Options
Also In This Category
Tags