THE INFORMATION IN THIS ARTICLE APPLIES TO:
SYMPTOMS
When upgrading from EFT Server v4.3.4 and prior to EFT 5.0, you receive an error and users are not be able to log in
CAUSE
The EFT Server v5.0 provides a new field in the user database called [SettingsLevel].
RESOLUTION
You need to add the new field [SettingsLevel] to the database, as shown below.
if exists (select * from sysobjects where id = object_id(N'[dbo].[ftpserver_ids]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[ftpserver_ids]
GO
if exists (select * from sysobjects where id = object_id(N'[dbo].[ftpserver_users]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[ftpserver_users]
GO
CREATE TABLE [dbo].[ftpserver_ids] (
[User_ID] [int] NULL ,
[Group_ID] [int] NULL
) ON [PRIMARY]
GO
CREATE TABLE [dbo].[ftpserver_users] (
[ID] [int] IDENTITY (1, 1) NOT NULL ,
[name] [varchar] (50) NULL ,
[password] [varchar] (200) NULL ,
[description] [varchar] (200) NULL ,
[type] [int] NULL ,
[password_type] [int] NULL ,
[md_iter] [int] NULL ,
[otp_seed] [varchar] (16) NULL ,
[anonymous] [int] NULL ,
[anonymous_email] [int] NULL ,
[FullName] [varchar] (200) NULL ,
[Email] [varchar] (200) NULL ,
[Phone] [varchar] (200) NULL ,
[Pager] [varchar] (200) NULL ,
[Fax] [varchar] (200) NULL ,
[Comments] [varchar] (200) NULL ,
[Enabled] [int] NULL,
[HomeDirectory] [varchar] (512) NULL,
[SettingsLevel] [varchar] (200) NULL
) ON [PRIMARY]
GO