Mail Express Server cannot connect to the GlobalSCAPE Registration Server


THE INFORMATION IN THIS ARTICLE APPLIES TO:

  • Mail Express, v3

SYMPTOM

Mail Express Server cannot connect to the GlobalSCAPE Registration Server.

CAUSE

Either the Mail Express Server is not connected to the Internet or connects to the Internet through a proxy.

RESOLUTION

If you must go through a proxy to access the Internet, Mail Express Server will most likely fail to contact the registration server. To resolve the issue, you must edit a configuration file to specify the proxy information.

To edit the configuration file

  1. On the Mail Express Server, open \conf\MailExpressServerService.conf in a text editor.
  2. Locate the "Additional Java Parameters" section.
  3. Add the following lines to the section:
    wrapper.java.additional.5=-Dhttp.proxyHost=<Proxy host or IP>
    wrapper.java.additional.6=-Dhttp.proxyPort=<Proxy port>
    Where <Proxy host or IP> is the hostname or IP address of the proxy server and <Proxy port> is the port to use on the proxy server.
  4. Restart the Mail Express Server.
  5. Proceed with registration.