Scheduled Timer stopped working for 1 hour after DST ended


THE INFORMATION IN THIS ARTICLE APPLIES TO:

  • All Products

SYMPTOM

A scheduled timer stopped working for 1 hour after DST ended. Then an hour after the time change, the scheduled timer kicked off again.

CAUSE

Since 2007, the United States has observed Daylight Saving Time (DST) from the second Sunday in March at 2 am, until the first Sunday in November at 2 am. Most of Canada also observes DST at this time. For example:

Start of DST: Sunday, March 8, 2020, 2:00:00 am clocks were turned forward 1 hour to Sunday, March 8, 2020, 3:00:00 am local daylight time instead.
End of DST: Sunday, November 1, 2020, 2:00:00 am clocks were turned backward 1 hour to Sunday, November 1, 2020, 1:00:00 am local standard time instead.

EFT uses the underlying operating system's timer hooks, which operates the same as Windows, which itself has a few inconsistencies when DST changes occur for frequently recurring events. Per Microsoft Support:

Many applications and cloud services reference the underlying Windows operating system for daylight saving time (DST) and time zone (TZ) information. To make sure that Windows has the latest and most accurate time data, Microsoft continuously monitors DST and TZ changes that are announced by governments around the world. Microsoft makes an effort to incorporate these changes to Windows, and publishes an update through Windows Update (WU). Each DST and TZ update that is released through WU will have the latest time data and will also supersede any previously issued DST and TZ update.

RESOLUTION/WORKAROUND

If you have time-sensitive event rules, you can do one or more of the following:

  • Ensure your operating system is always up to date
  • Turn off DST on the operating system 
  • Enable UTC/GMT in EFT instead of the local server time

To specify the default time stamp

  1. In the administration interface, connect to EFT and click the Server tab.

  2. On the Server tab, click the Server that you want to manage.

  3. In the right pane, click the General tab.

  4.  In the Directory listing date stamp settings area, click one of the following:

    • Use local server time

    • Use UTC/GMT time

  5. Click Apply to save the changes on EFT.

Please report any other DST-related issues directly to the Technical Support Team.