Search

GlobalSCAPE Knowledge Base

Imported PGP private key cannot be used if passphrase includes any spaces

Karla Marsh
EFT Express (SMB) & Enterprise

THE INFORMATION IN THIS ARTICLE APPLIES TO:

  • EFT Server version 5.2 - 5.2.4 (This issue is resolved in EFT Server version 5.2.5.)

SYMPTOM

An invalid passphrase message appears when you type the OpenPGP passphrase for an imported OpenPGP key pair that was created in EFT Server version 5.2 to 5.2.4.

RESOLUTION

In EFT Server version 5.2 to 5.2.4, if you create an OpenPGP key with a passphrase that has spaces in it and import it into EFT Server 5.2 to 5.2.4, the passphrase will truncate before the space.

For example, suppose you created a key with the passphrase my passphrase in EFT Server 5.2, exported it, then imported it into EFT Server 5.2.3. When you type the passphrase my passphrase, an invalid passphrase message appears. Because the passphrase was truncated before the space, the expected passphrase was my.

A workaround is to surround the passphrase with quotation marks: "my passphrase"

For more information about OpenPGP in EFT Server, refer to "OpenPGP" in the help documentation.

Details
Last Modified: 5 Months Ago
Last Modified By: kmarsh
Type: FIX
Article not rated yet.
Article has been viewed 10K times.
Options
Also In This Category
Tags