THE INFORMATION IN THIS ARTICLE APPLIES TO:
- CuteFTP® Home version 6
- CuteFTP Pro® version 6
SYMPTOMS
The following error message occurs at run time when you are trying to uninstall, repair, or update an installation:
Error 1628: Failed to complete script based install.
There are three possible causes, all of which have to do with the Windows Installer system component.
POSSIBLE CAUSE 1
The uninstallation log file is corrupt.
RESOLUTION 1
Follow these steps to open Windows Task Manager and end the IDriver.exe process:
- On your keyboard, press CTRL + ALT + DEL and then click Task Manager.
- On the Processes tab find idriver.exe, select it and then click End Process.
- Close Windows Task Manager and run the CuteFTP setup file again.
POSSIBLE CAUSE 2
There is a conflict between one or more files in the Windows Temp folder and the files used by the installer.
RESOLUTION 2
Follow the steps below to delete the contents of the Windows Temp folder.
- Close all open programs.
- Start Windows Explorer and navigate to your Windows Temp folder. (There may be more than one Windows Temp folder being used on your computer. For example at C:\WINDOWS\Temp or at C:\Documents and Settings\USERNAME\Local Settings\Temp)
- Delete all of the files and folders in your Windows Temp folder.
- When finished, restart your computer and run the CuteFTP setup file again.
POSSIBLE CAUSE 3
Windows Installer is not properly configured on your computer or a more recent version of Windows Installer is required.
RESOLUTION 3
See the following Microsoft knowledge base article for further instructions: http://support.microsoft.com/kb/555175
When finished, restart your computer and run the CuteFTP setup file again.